
<!doctype html>
<html lang="en" class="no-js">
<head>
	<meta charset="utf-8">
	<meta name="viewport" content="width=device-width, initial-scale=0.96" />
	<meta property="og:url" content="https://publicaddress.net/radiation/july-18-views-pasifika-comedy-london-drama/" />
	<meta property="og:image" content="/static/img/publicaddress-logo.png?k=03d2cd7ba3" />
	
	<link rel="alternate" type="application/rss+xml" title="Public Address RSS Feed" href="/all.rss" />
	<link rel="canonical" href="https://publicaddress.net/radiation/july-18-views-pasifika-comedy-london-drama/">
	<link rel="shortlink" href="https://pubadr.es/11477">
	<link rel="shortcut icon" type="image/png" href="/static/img/favicon.png?k=03d2cd7ba3" />
	<link rel="apple-touch-icon" href="/static/img/apple-touch-icon.png?k=03d2cd7ba3">

	<link href="/css/c.css?set=css&amp;v=1504142324000" rel="stylesheet" type="text/css" media="all"/>
	<link href="/css/c.css?set=css-layout&amp;v=1440553482000" rel="stylesheet" type="text/css" media="all"/>
	<link href="/css/c.css?set=css-handheld&amp;v=1440553482000" rel="stylesheet" type="text/css" media="handheld"/>
	<link href="/css/c.css?set=css-print&amp;v=1440553482000" rel="stylesheet" type="text/css" media="print"/>

	<!--[if lte IE 8 ]>
		<link href="/css/c.css?set=css-print-ie&amp;v=1440553482000" rel="stylesheet" type="text/css" media="print"/>
	<![endif]-->
	<!--[if IE 7 ]>
		<link href="/css/c.css?set=css-ie7&amp;v=1440553482000" rel="stylesheet" type="text/css" media="all"/>
	<![endif]-->
	<!--[if lt IE 7 ]>
		<script src="/static/js/dd_belatedpng.js"></script>
		<link href="/css/c.css?set=css-ie6&amp;v=1440553482000" rel="stylesheet" type="text/css" media="all"/>
		<script>DD_belatedPNG.fix('#logo, .dotted, .icon span, .video-thumb span');</script>
	<![endif]-->

	
	<title>July 18 Views: Pasifika comedy, London drama, Aussie kids &bull; Radiation &bull; Public Address</title>

	<script src="/js/c.js?set=js&amp;v=1489443320000" ></script>
	<script src="/static/js/typekit.js?k=03d2cd7ba3"></script>

	<link href="/global.css?mod=20200716132506" rel="stylesheet" type="text/css" media="all"/>
	<link href="/css/c.css?set=css-blog&amp;v=1440553482000" rel="stylesheet" type="text/css" media="all"/> <link rel="alternate" type="application/rss+xml" title="Radiation RSS Feed" href="/radiation/rss/" /> <link href="/radiation.css?mod=20200716132506" rel="stylesheet" type="text/css" media="all"/> <meta name="author" content="Fiona Rae"> <script type="text/javascript"> $('#currentPageLink').val(location.pathname); var baseUrl = "/system"; </script> <script src="/static/system/js/forum.js?k=782be1ef37" type="text/javascript"></script>
	
	
	
	<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
	<script>
		var googletag = googletag || {};
		googletag.cmd = googletag.cmd || [];
	</script>
	<script>
		googletag.cmd.push(function() {
			googletag.defineSlot('/1688062/PublicAddress_Big-Banner', [760, 120], 'div-gpt-ad-1554167184701-0').addService(googletag.pubads());
			googletag.defineSlot('/1688062/PublicAddress_Rectangle', [300, 250], 'div-gpt-ad-1554167057802-0').addService(googletag.pubads());
			googletag.defineSlot('/1688062/PublicAddress_Premium-Rectangle', [300, 250], 'div-gpt-ad-1554167135185-0').addService(googletag.pubads());
			googletag.defineSlot('/1688062/Ffunnell_Tile_A', [160, 300], 'div-gpt-ad-1554167249500-0').addService(googletag.pubads());
			googletag.defineSlot('/1688062/PublicAddress_SkyScraper', [160, 600], 'div-gpt-ad-1554167295447-0').addService(googletag.pubads());
			googletag.pubads().enableSingleRequest();
			googletag.pubads().collapseEmptyDivs();
			googletag.pubads().setTargeting('Site', ['PublicAddress']);
			googletag.enableServices();
		});
	</script>
	

	<script>var siteroot = "/";var csrf = "xSEvDsVE2Tf7PUdS";</script>
	<script src="/js/c.js?set=js-header&amp;v=1554171154000"></script>
	<script>(function(d) {
	var el, fjs = d.getElementsByTagName('script')[0];
	el = d.createElement('script');
	el.id = "js-pp-banner";
	el.src = "//dashboard.presspatron.com/dev/banner?b=EQ59A3cp8JqAMEoa9b5pbf3q";
	fjs.parentNode.insertBefore(el, fjs);
}(document));</script>
</head>

<body class=" ">
	<script type="text/javascript" src="/js/c.js?set=osdetect&amp;v=1440553482000" ></script>
	







	<div id="pp-banner"></div>
	<div id="container" class="blog">
		<header id="title">
			<a id="logo" href="/">Public Address, a community of blogs</a>
			<div id="ad-leaderboard">
				
				<div id="div-gpt-ad-1554167184701-0">
					<script>googletag.cmd.push(function() { googletag.display("div-gpt-ad-1554167184701-0"); });</script>
				</div>
			</div>
			
		<a href="/radiation/"><h1>Radiation <em>by Fiona Rae</em></h1></a>
	
		</header>


	

	






<div id="main" class="tk hfeed">
	


<article class="hentry radiation" id="post11477">
	<header>
		<div class="meta">
			<time datetime="2020-07-16T12:59:00+1200" class="published updated" pubdate>12:59 Jul 16, 2020</time>
			
			
				
				
						
					
				
						<a class="icon comments" href="/radiation/july-18-views-pasifika-comedy-london-drama/#comments" title="0 responses">0</a>
					
			
		</div>
		<h3 class="entry-title"><a href="/radiation/july-18-views-pasifika-comedy-london-drama/">July 18 Views: Pasifika comedy, London drama, Aussie kids</a></h3>
		
	</header>

	

	
		
	
	
	
	
	
	<div class="entry-content prettify">
		
				
				
					<p><strong>SATURDAY JULY 18</strong></p>
<p><strong>ANZ Premiership Netball (Sky Sport 3, 5.00pm).&nbsp;</strong>Top of the table Central Pulse meet next-on-the-ladder Mystics today; tomorrow, the Pulse meet the Tactix, also at 5pm, followed by Steel v Magic at 7pm. On Monday, it's Steel v Tactix at 7pm.&nbsp;</p>
<p><strong>Super Rugby Aotearoa (Sky Sport 1, 6.30pm).&nbsp;</strong>The Hurricanes meet the Blues at their home ground tonight; can the Blues rise above the crushing Crusaders loss from last week? Tomorrow, it's Chiefs v Highlanders at Stadium Waikato (Sky Sport 1, 3pm).</p>
<p><strong>Cricket (Spark Sport, 9.58pm).</strong> The 2nd England v West Indies test goes into its third day; England were 469-9 declared at the end of day two after a lovely 176 from Ben Stokes and a 120 knock&nbsp;<span>Dom Sibley. In reply, the Windies were 32 for 1.</span></p>
<p><strong>SUNDAY JULY 19</strong></p>
<p><strong>NRL (Sky Sport 4, 3.30pm).</strong> The Warriors meet the Cronulla Sharks at Central Coast Stadium – the Sharks are not having a stellar season either; they're currently at No 9 on the ladder, although the Warriors languish at No 13.&nbsp;</p>
<p><strong>MONDAY JULY 20</strong></p>
					
						
						<div class="premium-rectangle-ad">
							
							<div id="div-gpt-ad-1554167135185-0">
								<script>googletag.cmd.push(function() { googletag.display("div-gpt-ad-1554167135185-0"); });</script>
							</div>
						</div>
					
				
					<p><strong>Gangs of London (SoHo, Sky 010, 9.30pm and Neon).</strong> Gareth Evans, that unlikely champion of Indonesian martial arts, returns to the UK for a big, bad gangster saga. The words "epic" and "Shakespearean" are bandied about in <a href="https://www.pulsefilms.com/work/item/gangs-of-london-out-today" target="_blank">the promo</a>, but let's face it, we're really here for the action scenes. This is the guy who brought us <em>The Raid</em>, after all. Joe Cole plays a crime boss's son who goes on the warpath after his father is killed. Colm Meaney is his dad and Michelle Fairley (<em>Game of Thrones</em>) is his mum and the cast also features the veteran Lucian&nbsp;<span>Msamati (most recently John Faa in <em>His Dark Materials</em>), Paapa Essiedu (<em>I May Destroy You</em>) and, presumably in a nod to his native Wales, Mark Lewis Jones and Richard Harrington as Welsh travellers.</span></p>
<p><strong>TUESDAY JULY 21</strong></p>
<p><strong>Portrait Artist of the Year (Sky Arts, Sky 020, 8.30pm).&nbsp;</strong>Season six, and portraitees include John Cooper Clarke, Tinie Tempah, Russell Tovey,&nbsp;<span>Wunmi Mosaku</span> and Harriet Walter. The winner gets a commission to paint Nile Rodgers.</p>
<p><strong>Ackley Bridge (UKTV, Sky 007, 9.30pm).</strong> Another good one for the school hols (are they still on?); the multicultural drama about two merged schools returns for a second season. It's a raucous show that was a surprise hit with teens, <a href="https://www.theguardian.com/tv-and-radio/2019/jun/18/ackley-bridge-channel-4-school-drama-surprise-hit-with-meme-loving-teens" target="_blank">said the <em>Guardian</em></a>.</p>
<p><strong>WEDNESDAY JULY 22</strong></p>
<p><span><strong>Sis (Comedy Central, Sky 011, 8.30pm).</strong> The new comedy from&nbsp;<em>Baby Mama’s Club</em><span>&nbsp;creator&nbsp;</span><span>Hanelle Harris is about a group of Pasifika writers tasked with creating a new comedy show, except their head writer is an idiot. Hm, they say write what you know ...</span></span></p>
<p><strong>THURSDAY JULY 23</strong></p>
					
				
					<p><span><strong>Save Me Too (SoHo, Sky 010, 8.30pm).</strong>&nbsp;The brilliant&nbsp;Lennie James created, wrote and starred –&nbsp;and was Bafta-nominated – in&nbsp;<em>Save Me</em>, the drama series about a flawed South-east Londoner whose daughter goes missing. In the second season, Nelly's search continues and he is focused on Grace, the girl he inadvertently saved last season, who may know something about Jody's whereabouts. It's going to be tense and James will,&nbsp;<span>indubitably, be excellent. Adrian Edmonson plays a drug dealer (!), Suranne Jones is Nelly's ex-wife, and Stephen Graham, who was in the last series of <em>Line of Duty</em>, is Nelly's friend and convicted sex offender who swears he's been rehabilitated.</span></span></p>
<p><strong>STREAMING AND ELSEWHERE</strong></p>
<p><strong><a href="https://www.tvnz.co.nz/shows/first-day/episodes/s1-e1" target="_blank">First Day</a> (TVNZ OnDemand).</strong> An Australian mini-series that is based on a short film that won an award at&nbsp;the inaugural MIPCOM Diversify TV Excellence Awards in 2018. Filmed in Adelaide, the series follows Hannah, a&nbsp;transgender girl, as she begins high school. Hannah is played by&nbsp;Evie Macdonald, who famously <a href="https://qnews.com.au/transgender-13-year-old-calls-out-scott-morrison-for-his-disrespectful-tweet/" target="_blank">called out Aussie PM Scott Morrison</a> on a crappy anti-trans tweet. A good one for the school hols.</p>
<p><strong>Auckland Writers Festival 2020 Winter Festival (Sunday, 9.00am).</strong> The writers festival winter festival is up to its penultimate episode, and this Sunday features&nbsp;English novelist Patrick Gale (<em>Take Nothing With You</em>),&nbsp;Austrian author Julia Ebner (<em>Going Dark: The Secret Social Lives of Extremists</em>)&nbsp;and NZ’s inaugural Poet Laureate Michele Leggott (<em>Mezzaluna: Selected Poems</em>). You can watch live on the <a href="https://www.facebook.com/AklLive/" target="_blank">Auckland Live Facebook</a> or <a href="https://www.youtube.com/user/AKwritersFESTIVAL" target="_blank">Writer's Festival YouTube</a>, or watch later on the <a href="http://www.writersfestival.co.nz/look-and-listen/videos/" target="_blank">website</a>. Next week's final episode features Ann Patchett and Maggie O'Farrell (<em>Hamnet</em>).</p>
					
				
					<p><strong>Love Life (TVNZ OnDemand, Thursday).</strong> I dunno, the relationship trials and tribulations of a young, white woman seem so 2018, amiright? Based solely on the trailer, it appears to be a more privileged <em>High Fidelity</em> (there's even a link: Kingsley Ben-Adir, who is Sexy English Guy in <em>HF</em>) and inhabits a New York that only exists in rom coms. However, if there's one actor who can rescue anything, it's Anna Kendrick, so if you're looking for something really lightweight, have at it.</p>
					
				
			
	</div>

	
			


	<footer>
		<div class="meta">
			
				
						<a class="icon comments" href="/radiation/july-18-views-pasifika-comedy-london-drama/#comments">Respond</a>
					
			
			<a class="icon reply" href="/radiation/july-18-views-pasifika-comedy-london-drama/reply/">Email</a>
			<a class="icon share" href="#">Share</a>

			<ul class="share-options">
				<li><input type="text" class="shortlink" value="https://pubadr.es/11477"/></li>
				<li><a href="http://twitter.com/share" class="twitter-share-button" data-url="https://pubadr.es/11477" data-text="July 18 Views: Pasifika comedy, London drama, Aussie kids" data-count="none">Tweet</a><script type="text/javascript" src="//platform.twitter.com/widgets.js"></script></li>
				<li class="facebook-like"><iframe src="//www.facebook.com/plugins/like.php?href=https://publicaddress.net/radiation/july-18-views-pasifika-comedy-london-drama/&amp;layout=button_count&amp;show_faces=false&amp;width=100&amp;action=like&amp;font=lucida+grande&amp;colorscheme=light&amp;height=21" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:100px; height:21px;" allowTransparency="true"></iframe></li>
			</ul>
		</div>

		
			<section class="donate-banner">
				<a href="/supporters/">Help sustain Public Address: <span>Become a supporter</span></a>
			</section>
		
	</footer>

		
	
	
	
</article>
	
		<div class="centred-tile">
	<div class="rectangle-ad">
		
		<div id="div-gpt-ad-1554167057802-0">
			<script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1554167057802-0'); });</script>
		</div>
	</div>

</div>

		<!-- COMMENTS -->
		
	
		
		
		
		
		
				
			
		
		<h3 class="subheading">0 responses to this post</h3>
		
		
		<ul class="responses" id="comments">
			
					<li>
						<header class="response-meta">
							<p><a href="#" class="response-author">No comments</a></p>
						</header>
					</li>
				
		</ul>
		<footer>
			
					
					
<div class="comment-form" id="forum-reply-">
	<h2 id="forum-reply">Post your response&hellip;</h2>
	
			
					
				
			

<form method="post" action="/user/login.do" id="login_form" class="form form-box form-inline" onsubmit="if( $('#nextUrlLarge').val() == '' ) { $('#nextUrlLarge').val(location.pathname + location.search); }"><input type="hidden" name="__csrf" value="xSEvDsVE2Tf7PUdS" />
	
	<p><em>Please sign in using your Public Address credentials&hellip;</em></p>
	<input type="hidden" name="next" id="nextUrlLarge" value="/radiation/july-18-views-pasifika-comedy-london-drama/#comments" />
	<fieldset>
		<legend>Login</legend>
		<div class="row">
			<label for="form-username" class="left">Username</label>
			<input type="text" name="username" id="form-username" class="field" size="20" value="" />
		</div>
		<div class="row">
			<label for="form-password" class="left">Password</label>
			<input type="password" name="password" class="field password-field" id="form-password" size="20" />
		</div>
		<div class="row remember-me">
			<label for="form-remember" class="checkbox_label">
				<input type="checkbox" name="remember" id="form-remember" class="checkbox" value="true" /> 
				Remember me
			</label>
		</div>
		<div class="buttons">
			<input type="submit" value="Sign In" class="button" />
		</div>
	</fieldset>
</form>

<p>You may also <a href="/user/register">create an account</a> or <a href="/user/forgotten">retrieve your password</a>.</p>

		
</div>
<div id="post-preview" class="response-content"></div>

					<script type="text/javascript">
						initTopic();
						
						var h = "";
						if( h != "" ) {
							location.hash = h;
						}
					</script>
				
		</footer>
					
	

	
</div>




		<aside id="centre" class="tk">
			<h1 class="hidden">Navigation</h1>

			<section class="donate-banner">
				<a href="/supporters/">Help sustain Public Address: <span>Become a supporter</span></a>
			</section>
			
			
	
		<section id="login">
			
					<h2 class="hidden">Sign In</h2>
					
					<form method="post" action="/user/login.do" class="login-form" onsubmit="$('#nextUrl').val(location.pathname + location.search);"><input type="hidden" name="__csrf" value="xSEvDsVE2Tf7PUdS" />
						<input type="hidden" name="next" id="nextUrl" value="" />
						<fieldset>
							<div class="row">
								<label for="username" class="tk-ad">Username</label>
								<input type="text" name="username" id="username" class="field" value="" />
							</div>
							<div class="row">
								<label for="password" class="tk-ad">Password</label>
								<input type="password" name="password" id="password" class="field password-field" value="" />
							</div>
							<div class="buttons">
								<label for="remember" class="checkbox-label"><input type="checkbox" name="remember" id="remember" value="true" /> Remember Me</label>
								<input type="submit" value="Sign In" class="button"/>
								<p class="forgotten"><a href="/user/register">Sign up</a> &bull; <a href="/user/forgotten">Forgotten password?</a></p>
							</div>
						</fieldset>
					</form>
				
		</section>
	

	
		<section>
			<h2>Recent</h2>
			<nav class="recent slab">
				<ul>
					
						<li><a href="/radiation/july-18-views-pasifika-comedy-london-drama/">July 18 Views: Pasifika comedy, London drama, Aussie kids</a></li>
					
						<li><a href="/radiation/july-12-views-tom-sainsburys-sex-scandal/">July 12 Views: Tom Sainsbury&#039;s sex scandal</a></li>
					
						<li><a href="/radiation/july-5-views-murders-devils-and-kinks/">July 5 Views: Murders, Devils and Kinks</a></li>
					
				</ul>
				<footer>
					<ul class="dotted">
						<li><a href="/radiation/archive/">Radiation Archive</a></li>
						<li><a href="/radiation/rss/" class="icon rss">RSS Feed</a></li>
					</ul>
				</footer>
			</nav>
		</section>
	

		
			<nav id="blogs">
				<h2>Blogs</h2>
				<ul>
					
					
						
						<li><a href="/hardnews/" class="hardnews">Hard News</a></li>
					
						
						<li><a href="/cracker/" class="cracker">Cracker</a></li>
					
						
						<li><a href="/busytown/" class="busytown">Busytown</a></li>
					
						
						<li><a href="/fieldtheory/" class="fieldtheory">Field Theory</a></li>
					
						
						<li><a href="/onpoint/" class="onpoint">OnPoint</a></li>
					
						
						<li><a href="/southerly/" class="southerly">Southerly</a></li>
					
						
						<li><a href="/legalbeagle/" class="legalbeagle">Legal Beagle</a></li>
					
						
							</ul>
							<ul>
						
						<li><a href="/up-front/" class="upfront">Up Front</a></li>
					
						
						<li><a href="/muse/" class="muse">Muse</a></li>
					
						
						<li class="selected"><a href="/radiation/" class="radiation">Radiation</a></li>
					
						
						<li><a href="/im:8577/" class="notesandqueries">Notes+Queries</a></li>
					
						
						<li><a href="/envirologue/" class="envirologue">Envirologue</a></li>
					
						
						<li><a href="/polity/" class="polity">Polity</a></li>
					
				</ul>
				<footer>
					<ul class="dotted">
						
							<li class=" "><a href="/speaker/" class="speaker">Speaker</a></li>
						
							<li class=" "><a href="/capture/" class="capture">Capture</a></li>
						
							<li class=" "><a href="/feed/" class="feed">Feed</a></li>
						
							<li class=" "><a href="/access/" class="access">Access</a></li>
						
							<li class=" fullwidth"><a href="/access-granted/" class="accessgranted">Access Granted</a></li>
						
							<li class=" fullwidth"><a href="/great-new-zealand-argument/" class="gnza">Great New Zealand Argument</a></li>
						
					</ul>
				</footer>
				<div class="dotted">
					<ul>
						<li><a href="/system/">PA.System</a></li>
					</ul>
					<ul>
						<li><a href="/radio/">PA.Radio</a></li>
					</ul>
				</div>
			</nav>
			
			
				<section id="search">
					<h2>Search</h2>
					
					<form method="get" action="/search.do" id="searchform">
						<input type="text" name="q" id="searchfield" class="tk" value="" />
						<a href="#" id="searchsubmit">Go</a>
					</form>
				</section>
				
				<div class="adverts">
					
					<div id="div-gpt-ad-1554167249500-0">
						<script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1554167249500-0'); });</script>
					</div>
					
					
					<div id="div-gpt-ad-1554167295447-0">
						<script>googletag.cmd.push(function() { googletag.display("div-gpt-ad-1554167295447-0"); });</script>
					</div>
	
					<section class="scoopads">
						<h4><a href="http://www.scoop.co.nz/about/advertising.html">Ads by Scoop</a></h4>
					</section>
				</div>

			
		</aside>
		
		<aside id="right" class="tk">
			
				
					
				
	
				
		<div class="group">
			<section>
				<h2>Links</h2>
				<nav>
					<ul>
		 				
							<li>
<a href="/about-fiona-rae/">About Fiona Rae</a></li>
						
					</ul>
				</nav>
			</section>
		</div>
	
				
				




	<div class="group">
		<section>
			<h2>On Twitter</h2>
			<p class="on-twitter"><a href="http://twitter.com/FionaRae">@FionaRae</a></p>
			
		</section>
	</div>
	


			

			 
		</aside>

		 

		<footer id="footer">
			<p>&copy;2002-2020 Public Address, all rights reserved. <a href="/disclaimer-1/">Disclaimer</a>. <span class="cactuslab">Made by <a href="http://www.cactuslab.com/">Cactuslab</a>. Powered by <a href="http://www.supermodel.co.nz/">Supermodel</a>.</span></p>

			<p class="fonts">
				Fonts by <a href="http://typekit.com/colophons/wte6oca">Typekit</a> (<a href="#" id="typekitToggle">disable</a>)
				<span class="wide-view"><a href="#" id="layoutToggle">Show wide layout</a></span>
			</p>
			<form style="display:none;" action="/layout.do" method="post">
				<input type="hidden" name="next" id="layoutNext" value=""/>
			</form>
			<form style="display:none;" action="/typekit.do" method="post">
				<input type="hidden" name="next" id="typekitNext" value=""/>
			</form>
			
		</footer>
	</div>


<!-- START Nielsen Online SiteCensus V6.0 -->
<!-- COPYRIGHT 2010 Nielsen Online -->
<script type="text/javascript" src="//secure-nz.imrworldwide.com/v60.js">
</script>
<script type="text/javascript">
 var pvar = { cid: "nz-publicaddress", content: "0", server: "secure-nz" };  var trac = nol_t(pvar);  trac.record().post(); </script> <noscript>  <div>  <img src="//secure-nz.imrworldwide.com/cgi-bin/m?ci=nz-publicaddress&amp;cg=0&amp;cc=1&amp;ts=noscript"
 width="1" height="1" alt="" />
 </div>
</noscript>
<!-- END Nielsen Online SiteCensus V6.0 -->

</body>
</html>